Forums

Forums / Bugs & Issues / ThePortalConnector Configuration Empty

ThePortalConnector Configuration Empty

9 posts, 2 answered
  1. Sakkie Koekemoer
    Sakkie Koekemoer avatar
    6 posts
    Registered:
    21 Jun 2021
    25 Jun
    Link to this post
    Hi 

    We have a new version setup in azure and installed all portal connector modules. But when we go to the configuration screen to setup the connection tp D365 the screen is blank,

    Can anyone assist please?

    This is the first time we setup our own version so we might have missed something.

    we running TPC version 6.0.7626.137 and Sitefinity trial 13.3.7626.0
  2. Omar S
    Omar S avatar
    34 posts
    Registered:
    04 Jul 2019
    05 Jul in reply to Sakkie Koekemoer
    Link to this post
    Hello Sakkie
    For future reference, issues that involve troubleshooting are best resolved during our Q+A, If we are unable to resolve it during the short time there, then we may proceed to open a ticket. 

    Connection issues can range from TLS issues to using depreciated connection types,  Without looking at your TPC error logs, it would be hard to diagnose. As a tip, please set your error log verbosity to Developer. 
  3. Sakkie Koekemoer
    Sakkie Koekemoer avatar
    6 posts
    Registered:
    21 Jun 2021
    Answered
    06 Jul in reply to Omar S
    Link to this post
    Hi Omar

    Thanks for the reply

    We did not know that is a rule with this forum we will use the Q+A from now on first.
     
    With regards to the issue above, we managed to solve it we just forgot to update this ticket. The other Pavliks DLL also need to be included which the documentation is not saying.

    Will mark it as answered.
    Last modified on 06 Jul 2021 05:07 by Sakkie Koekemoer
  4. Omar S
    Omar S avatar
    34 posts
    Registered:
    04 Jul 2019
    06 Jul in reply to Sakkie Koekemoer
    Link to this post
    Hello Sakkie

    There is no rule. It just makes it easier to troubleshoot issues in person. What Dll did our documentation fail to mention?

    We have daily Q+A sessions. You can register here: https://www.crmportalconnector.com/support/training/daily-q-a-registration
    Last modified on 06 Jul 2021 19:07 by Omar S
  5. Sakkie Koekemoer
    Sakkie Koekemoer avatar
    6 posts
    Registered:
    21 Jun 2021
    Answered
    07 Jul in reply to Omar S
    Link to this post
    Hi Omar

    We did struggle for while before adding the question. Next time we will sign up for the Q+A.

    With regards to the missing info on the documentation. 

    If you look at this link https://www.crmportalconnector.com/developer-network/documentation/setup-portal-connector/installation/installing-tpc/installing-tpc-on-sitefinity-13 its saying add the DLLs references for the below list.

    pavliks.PortalConnector.dll 
    pavliks.PortalConnector.Mvc
    pavliks.PortalConnector.Mvc.Forms
    pavliks.PortalConnector.Mvc.Pages
    pavliks.PortalConnector.Mvc.FormFlow
    pavliks.PortalConnector.Migrations
    pavliks.PortalConnector.Mvc.PowerBI
    pavliks.PortalConnector.Mvc.KnowledgeBase

    But after chatting to Christopher Hicks at TPC. He helped us by adding the references to pavliks.PortalConnector.AdminApp, pavliks.PortalConnector.Auditing, pavliks.PortalConnector.Migrations and pavliks.PortalConnector.PowerPlatform.

    Adding these other references we managed to see the content of the 'ThePortalConnector Configuration' screen.
     
  6. Omar S
    Omar S avatar
    34 posts
    Registered:
    04 Jul 2019
    07 Jul in reply to Sakkie Koekemoer
    Link to this post
    Thank you for informing me. I will see to have our documentation up-to-date. In our previous versions, you did not need to reference optional dlls like Auditing, Migrations and PowerPlatform. However, for 6.0, you also need to reference these optional dlls. We will address this issue on TPC 6.1. That said, AdminApp is a required dll and should be always refenced going forward. 
  7. Sakkie Koekemoer
    Sakkie Koekemoer avatar
    6 posts
    Registered:
    21 Jun 2021
    08 Jul in reply to Omar S
    Link to this post
    No problem, Thanks, now we also know.

    Have a good day
    Sakkie
  8. Ernesto Andrade
    Ernesto Andrade avatar
    1 posts
    Registered:
    12 Jul 2021
    16 Jul
    Link to this post
    We're also experience this problem. The solution in this thread doesn't seem to work for us. We're on same versions as OP and hosting on Azure, can't get it to work locally either thought.

    From the Sitefinity error log we get this exception: 
    System.InvalidOperationException: 'The view 'Default' or its master was not found or no view engine supports the searched locations. The following locations were searched:
    ~/Views/AdminAppBackendView/Default.cshtml
    ...
  9. Adam Benoit
    Adam Benoit avatar
    13 posts
    Registered:
    01 Mar 2017
    16 Jul
    Link to this post
    Hi Ernesto,

    This issue is likely the same as described earlier in the thread.

    When you compile the application, Sitefinity runs a script that scans the assemblies in the bin folder of the application called ControllerContainerAsembliesLocation.json. In this file there needs to be references to the following Portal connector assemblies:

        "pavliks.PortalConnector.AdminApp.dll",
        "pavliks.PortalConnector.Auditing.dll",
        "pavliks.PortalConnector.dll",
        "pavliks.PortalConnector.Migrations.dll",
        "pavliks.PortalConnector.Mvc.dll",
        "pavliks.PortalConnector.Mvc.FormFlow.dll",
        "pavliks.PortalConnector.Mvc.Forms.dll",
        "pavliks.PortalConnector.Mvc.KnowledgeBase.dll",
        "pavliks.PortalConnector.Mvc.Pages.dll",
        "pavliks.PortalConnector.Mvc.PowerBI.dll",
        "pavliks.PortalConnector.PowerPlatform.dll",

    This should happen automatically but if the files are blocked by windows, the script cannot read them and they are not added to the file. Windows can block files downloaded from the internet.

    Try right clicking each one of the above files in the windows file explorer and checking the properties for an "Unblock" checkbox. if you see it, this file is blocked. Check the checkbox to unblock it and once all the above files are checked, try recompiling the application and see if the missing ones are in the file.

    Ultimately, nothing is stopping you from simply adding the above lines to the json file but that doesn't solve why they are missing in the first place.

    Hopefully this helps, please let me know if you have any questions.

    Last modified on 16 Jul 2021 12:07 by Adam Benoit
9 posts, 2 answered