Forums

Forums / Bugs & Issues / Sharepoint file widget

Sharepoint file widget

Thread is closed for posting
3 posts, 1 answered
  1. clefsrud
    clefsrud avatar
    26 posts
    Registered:
    24 Nov 2014
    28 Feb 2018
    Link to this post

    I have a lead form with a widget for uploading files to SharePoint which is not working.
    I have working instances of the widget on a different (custom entity) form; and a SharePoint file grid on a contact form which is also working correctly.  No issues with posting files against lead records directly in D365.  D365 and SP both online.
    What am I doing wrong?
    Differences:
    - the lead entity was not originally configured for SharePoint files, added later; republished metadata for good measure
    - widget was changed from Notes to SP; but then also tried adding a fresh duplicate widget for SP files, also did not work.
    - lead form with the widget is the second (last) form of a multi-form arrangement;

    Chris

  2. Adam Benoit
    Adam Benoit avatar
    7 posts
    Registered:
    01 Mar 2017
    Answered
    28 Feb 2018 in reply to clefsrud
    Link to this post
    Hi Chris,

    What version of TPC are you running? There were updates to SharePoint Online recently that required that we make some updates to get working again. If you are on an older version of TPC, you will likely need to upgrade to the latest version to get SharePoint working again.

    Adam
  3. clefsrud
    clefsrud avatar
    26 posts
    Registered:
    24 Nov 2014
    28 Feb 2018
    Link to this post

    As I have mentioned, it is working within the current environment and version; just not in a particular form.  Is there a reason why it might work in one form (two actually) and not another?

    Chris

3 posts, 1 answered